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Introduction 
The last thing developers need is wasting their time on unnecessary documentation and 

manual release process. 

 

SourceReleaser is a freeware that helps you with documenting and releasing selected versions 

of source files from Visual SourceSafe with minimal or no effort. 

 

How it works? 
Create and save a release project; developers open the project, add selected source file 

versions to it and save it. Then the person doing the release simply opens it and does the 

releases. SourceReleaser gets specified versions of the files from the SourceSafe, label them 

with correct version, executes attached commands and documents the release. 

 

Installation 
Run the installation file (setup.exe or SourceReleaserSetup.msi), and follow the on-screen 

instructions. 
 

To install SourceReleaser from CD-ROM, insert it in your drive and follow the on screen 

instructions. If the setup does not start automatically, open/explore the CD-ROM and run the 

installation file (setup.exe or SourceReleaserSetup.msi). 

 

Minimum Requirements 
CPU: Pentium 300 MHz or better 

RAM: 64MB or better 

Free hard disk drive space: 10 MB or more 

Operating System: Windows 98/ME/NT/2000/XP/Vista 

.NET framework 3.5 

Add SourceSafe Databases 
On the Tools menu, click Add SourceSafe Database 

Click on Browse button  on SourceSafe Database window. 

Browse and select the Srcsafe.ini file in the installed Data directory for Visual SourceSafe 

Click Add button and finally click OK. 

 

Create Release Project 
From the File menu, choose New. 

 

Toolbar:  

 

Enter SourceSafe login details and click OK. (No password is required if you are using 

windows authentication) 
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The new release project may be given a name using the Save or Save As command on the 

File menu. 

 

Add Commands 

On Release Project window, click “Add before commands” button  to add commands that 

executes before the release or click “Add after commands” button  to add commands that 

executes after the release. In file open dialog, browse and select exe/vbs/bat files and click 

OK. 

 

Note: Multiple commands can be added separated by semicolon.  

Open Existing Release Project 
From the File menu, choose Open.  

 

Toolbar:   

 

The file open dialog appears, navigate to the release project file (.rpf) and click OK. 

To open it directly without opening the application, in your windows explorer double-click 

the release project file (.rpf) 

 

Enter SourceSafe login details and click OK on the SourceSafe login prompt. (No password 

is required if you are using windows authentication) 

 

Save Release Project 
From the File menu, choose Save. 

 

Toolbar:  

 

If it is a new release project, file save dialog appears, navigate to your folder, give name and 

click OK.  

Remove Source Projects 
On Release Project window, select the Source Project and click “Remove Project” toolbar 

button.  

 

Select Source Project Action 
On the selected source project, choose release action from the Action dropdown. 

Release Actions: 
 Release 

 Get Only 

 Label Only 
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 Un Label 

 Skip 

 Revert 
 

Release: Gets the specified version and labels it. 

Get Only: Gets the specified version but does not label it. 

Label Only: Labels it but doesn’t get it. 

Un Label: Un-labels it. 

Skip: Does not do any action, simply skips it 

Revert: Replaces it with backed-up version and un-labels it. 

Note: Revert works only if the project is released previously with Source-Backup enabled  

 

Add Source Files 
 

Select the Source Project and click on “Add” toolbar button , on SourceSafe explorer 
window select the project, file and version and click OK. 

 

Add Source Files Using File Selection Wizard 
Select the Source Project and click on “File selection wizard” toolbar button , on file 

selection wizard window navigate and select your options, filters and check the file versions 

and click Finish. 

 

Note: It may take several minutes to create the list. 

Edit Source Files 
Select the Source Project, select the source file and click Edit toolbar button  or double 

click on the source file you want to edit, on SourceSafe explorer window select the project, 

file and version and click OK. 

Delete Source Files 
Select the Source Project, select the source file and click on Delete toolbar button  or press 

“Del” key. 

Reorder Source Files 
Select the Source Project, select the source file and up or down toolbar buttons  to 

reorder the files within the source project. 

 

Check Change History Conflicts 
From View menu choose “Check Change History Conflicts” or on Release project window 

click “Check change history conflicts” toolbar button  

It checks change history conflict for each file in the Release project.  

 

Change history conflict: The files that are checked-in by other users before your check-in and 

are not included in the release project. 
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Release Source 
From Release menu choose Release or on Release project window click “Release” toolbar 

button  

 

Note: Set release type to “Ready to Release” before release. 

 

To stop the release, on Release project window click "Stop" toolbar button  

 

Show Release Status Report 
From View menu choose “Show Release Status Report” or on Release project window click 

“Show Release Status Report” toolbar button  

Select the report fields on Report Status Fields window and click OK.  

 

Release Status: The status of the source files. 

 

Note: Local file version number may not be accurate all the time; sometimes, SourceSafe 

does not update the local version number for various reasons for example when it is checked 

out locally. 

View Release Document 
 

From View menu choose “View Release Document”  “In Browser” or “View Release 

Document” ” In Word”, it opens the html document in default web browser or in MS word. 

 

To open existing release document, from View menu choose “Open Release Document”  

“In Browser” or “Open Release Document”  “In Word”; in file open dialog, browse, select 

the log file (.xml) and click OK, it open the html log file in the default web browser or in MS 

word. 

Note: Some MS Office versions may prompt you to convert from html; choose html and 

click OK. 

 

View Release Log 
 

After completing the release, application prompts you to open the release log and you can 

open it simply by clicking OK. 

If you want to open the release log afterwards, From View menu choose “Open Release Log” 

 “In Browser” or “Open Release Log”  “In Word” in file open dialog browse, select the 

log file (.xml) and click OK, it open the html log file in the default web browser or in MS 

word. 

 

Note: Some MS Office versions may prompt you to convert from html; choose html and 

click OK. 
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View Release Summary Log 
 

From View menu choose “Open Release Summary Log”  “In Browser” or “Open Release 

Summary Log”  “In Word” in file open dialog browse, select the log file (.xml) and click 

OK, it open the html log summary file in the default web browser or in MS word. 

 

Note: Some MS Office versions may prompt you to convert from html; choose html and 

click OK. 

 

Print Release Project  
 

From File menu choose Print, on the print dialog select your print options and click print. 

 

Toolbar:  

 

To print preview, from File menu choose “Print Preview”. 

 

Toolbar:  

 

Note: To remove URL footer on print page, open your internet explorer and remove the 

footer on the page settings. 

 

Send Release Project 
 

From File menu choose SendE-mail, it opens the default email client with an html 

attachment of the release document.  

 

Options 
From Tools menu choose Options... 

 

User Preferences 
 

Toolbar Visible  

Default value: True 

Description: Sets Toolbar visibility is true or false 

 

Statusbar Visible  

Default value: True 

Description: Sets Statusbar visibility is true or false 

 

Default Release Type  

Default value: .NET Source 

Description: Sets default release type when a new release project is created. 
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Release Default Directory Path  

Default value: release 

Description: Sets default release directory path. 

 

Remember Login Values  

Default value: True 

Description: Saves last logged in SourceSafe user id, path and name if it is set to true   

 

Database Path  

Default value: Data 

Description: Last logged is SourceSafe path 

 

UserId  

Default value:  

Description: Last logged id SourceSafe user id 

 

Database Name  

Default value:  

Description: Last logged is SourceSafe name 

 

Default Release Status  

Default value: Not Released 

Description: Sets default release status when a new release project is created 

 

Application Settings 
 

Release Number Increment Hours   

Default value: 120 

Description: Sets duration in hours for release number increment. 

 

Release File Extension  

Default value: .rpf 

Description: Sets release project file extension  

 

Log Directory Path  

Default value: log 

Description: Sets log directory path. 

If you set only the directory name then it prefixes application directory path. 

e.g. 

dir = application path\dir\ 

c:\dir_path = c:\dir_path\ 

[my documents]\dir = my documents path\dir\ 

 

Temp Directory Path  

Default value: temp 

Description: Sets temp directory path. 

If you set only the directory name then it prefixes application directory path. 

e.g. 

dir = application path\dir\ 

c:\dir_path = c:\dir_path\ 
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[my documents]\dir = my documents path\dir\ 

 

Log Xsl File  

Default value: logxsl.xml 

Description: Xsl file name in the application directory that is used for log file html 

transformation. 

 

Log Summary Xsl File  

Default value: logsummaryxsl.xml 

Description: Xsl file name in the application directory that is used for log summary file html 

transformation. 

 

Release Xsl File  

Default value: releasexsl.xml 

Description: Xsl file name in the application directory that is used for release file html 

transformation. 

 

Release Types  

Default value: .NET Source, Java Source, Database Source, Reports, Files 

Description: Sets release types for release project; list will populate the release types 

dropdown. 

 

Log Release Action  

Default value: False 

Description: Sets whether to log the release process or not. 

 

Temp Files Clean Hours  

Default value: 24 

Description: Temp files will be cleaned after the specified hours 

 

License File Name  

Default value: license.txt 

Description: License file name that is in the applications folder. 

 

Help File Name  

Default value: sourcereleaser.chm 

Description: Help file name that is in the applications folder. 

 

Log File Extension  

Default value: .xml 

Description: Sets log file extension  

 

Release Document Email Message  

Default value: Please find the attached release project document 

Description: Sets default e-mail message. 

 

Data Directory Path  

Default value: data 

Description: Sets data directory path. 

If you set only the directory name then it prefixes application directory path. 

e.g. 

dir = application path\dir\ 
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c:\dir_path = c:\dir_path\ 

[my documents]\dir = my documents path\dir\:  

 

SourceSafe File Name  

Default value: sourcesafes.xml 

Description: Sets SourceSafe databases file name that is in data directory. 

 

Source Backup Directory  

Default value: sourcebackup 

Description: Sets source backup directory path. 

If you set only the directory name then it prefixes application directory path. 

e.g. 

dir = application path\dir\ 

c:\dir_path = c:\dir_path\ 

[my documents]\dir = my documents path\dir\ 

 

Source Backup  

Default value: False 

Description: Sets whether to back up the release source or not 

 

Release Prefix  

Default value: R 

Description: Sets default release prefix. 

 

Note: Restart the application after changing the application settings. 

Troubleshooting 
Error while opening the application: This may be because of application unable read the 

user preferences; to resolve, locate application data folder (usually it is in c:\documents and 

settings \user\ application data or c:\users\user\ application data) and locate kirans folder and 

delete the SourceReleaser.exe_Url_ …. folders. 

 

Folder/File access Error: This maybe because of security settings of the application folder; 

to resolve, give read/write permissions for application folder and its sub folders. 

Or move data, temp directories out of the application folder. 

 

Known Issues 
Window Flickering: Sometimes windows flicker when you add source file from SourceSafe 

explorer window. This is a bug/limitation in windows and currently there is no solution for it. 

 
Word Refresh: Word does not refresh when you view the same release document or log file 

which is already opened in word; workaround for this is, close the opened document and 

view/open it again. 

 

Print Preview: Print preview window always shows with minimum size; window needs to 

be manual resized. 

 

Source Project Control Resize: Source project control does not resize after removing source 

project; it will be resized after reopening the release project. 
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Limitations 
Source Project Reorder: It is not possible to change source projects order, workaround: 

open the .rpf file in xml/text editor and copy and paste the SourceProject element and its 

child elements. 

 

 


